Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 28, 2025 - 17:30 GMT+08:00
Scheduled
- Current Status First: Your latest candidate status now always appears at the top of the process timeline for instant clarity. - Regional Time Zones: You can now view all timestamps in Thailand, Malaysia, or Philippines time—whichever suits you best.
Posted May 28, 2025 - 17:09 GMT+08:00
This scheduled maintenance affected: Hire Central, Admin Central, and Authorization.